Jump to content

faulty sensor


RAIDER

Recommended Posts

  • Platinum Member

finally got round to sorting out why the abs / esp / traction control warning lights had come on on the commander , was getting a little concerned as my car was trying to stop the wheels from rolling on the tarmac ,turns out the abs sensor on the front hub had died leading the computer to think the tyre had lost grip so the abs system was trying to sort it out . took it to Northampton spent 54 quid and the diagnosis pointed to front d/s sensor ,then the fun part came when westaways said they could sort it for me , the cost being £168.82 for sensor but as they seize inside the hub it would be an extra £386.06 + vat and labour , for hub bearing too so I probably wouldn't have seen much change out of 900 quid if I had said yes  :icon_eek:, instead it sourced a genuine new mopar part off the internet for £79 slight difference in price :icon_lol: then spent about 2 hours fitting it , all sorted now and good to go  :icon_e_biggrin:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

guidelines