Jump to content

XJ Cherokee 4L auto. Year 2000.


Richard Bellamy

Recommended Posts

  • Platinum Member
Richard Bellamy

Hi.

 

I've recently purchased this jeep and it's now running really well - just fine. Had usual hot running engine; spluttering idle when re-starting issues but now fixed.

 

My electric airial intermittently fails to pop up (front drivers wing). I hear a click so electrics fine. It's happened a few times.

Just when I decide to investigate it - the thing starts working again!

Just wondered if anyone else had a similar experience and fix?

IMG_1701.thumb.JPG.b20c4d0abf5da58ea5ae9f014cf05610.JPG

Link to comment
Share on other sites

  • Platinum Member

hi..the drive cable it made of nylon..and it has teeth...some teeth maybe damaged on your one or maybe some other internal fault or wear in the antenna parts..my drive cable broke..so i had no antenna at all...so i had to source a replacement antenna..fitted it and all is now fine...hope that helps you... :icon_e_smile:

Link to comment
Share on other sites

  • Platinum Member

My aerial stopped working but I still get reception. Plus I listen to CD as most radio play is bollox these days...but I still get reception....even in Scotland so its working grand for me.

Link to comment
Share on other sites

  • 3 weeks later...
  • Platinum Member

Welcome to the club, lovely XJ, and I like the look of that YJ hiding off to the side!

 

It's the square headlights Harry..... :icon_e_wink:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

guidelines